Từ 1 tới 2 trên tổng số 2 kết quả

Đề tài: lỗi Khi chạy ứng dụng trên điện thoại thì chỉ xuất hiện màn hình đen trên máy ảo thì vẫn chạy tốt

  1. #1
    Ngày gia nhập
    11 2010
    Bài viết
    9

    Mặc định lỗi Khi chạy ứng dụng trên điện thoại thì chỉ xuất hiện màn hình đen trên máy ảo thì vẫn chạy tốt

    Em đang viết một ứng dụng nhỏ nhưng khi chạy trên điện thoại thật ( hệ điều hành phiên bản 4.0 ICS) thì chỉ xuất hiện màn hình đen thui .... nếu code cho Toast Message thì vẫn xuất hiện mình thường.
    Máy em đã root + up room Sabsa Prime . Up từ room gốc là 2.2 .. nhưng up lên thì vào xem thông tin là 4.0. tại trên các diễn đàn có thảo luận về vụ này 2.2 bị màn hình đen 2.3 thì hết... nhưng em đã sử dụng AVD chạy ở 2.2 và 2.3 thì tất cả đều bình thường ...
    Mong ace trong diễn đàn giúp giùm em. Em xin trân thành cảm ơn

  2. #2
    Ngày gia nhập
    09 2010
    Nơi ở
    Hà nội
    Bài viết
    210

    Kiểm tra lại nhé :
    phần mềm của bạn có đọc ghi thẻ SD ( vui lòng tắt cái đọc dữ liệu từ thẻ SD với máy tính )
    phần mềm của bạn có thể có minSDKVersion lớn hơn hdh máy thật ( trong manifest )
    cuối cùng :
    bật cái enable debug từ điện thoại lên và vào logcat coi lỗi gì
    - 2 khả năng :
    + hiện logcat đỏ lòm -> ok biết lỗi r nhé
    + hiện cái debug (yes/no) -> chọn yes ( nhấn cái resume ở eclipse ấy -> hiện logcat đỏ lòm)
    = > post cái logcat lên đây giúp tiếp )
    Quá yêu em khiến em xem
    Đó như là sơ hở
    Em điểu khiển và biến tôi thành 1 thằng khở

Các đề tài tương tự

  1. ajax chạy trên ie thì đúng mà trên chorme lại chạy sai
    Gửi bởi tuanngocpt trong diễn đàn Thắc mắc lập trình ASP.NET
    Trả lời: 6
    Bài viết cuối: 20-02-2012, 11:45 PM
  2. Bài tập C Bài tập chạy được trên Borland C nhưng ko chạy được trên visual studio
    Gửi bởi P.K trong diễn đàn Thắc mắc lập trình C/C++/C++0x
    Trả lời: 7
    Bài viết cuối: 07-02-2012, 12:45 PM
  3. Thủ thuật C++ Built file sis để chạy trên điện thoại với Qt
    Gửi bởi thieugiabk trong diễn đàn Thủ thuật, Tutorials và Mã nguồn C/C++/C++0x
    Trả lời: 0
    Bài viết cuối: 25-10-2011, 11:37 AM
  4. C#.Chương trình chạy được trên WinXP, không chạy được trên Win7, Vista
    Gửi bởi qhhqnavy trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 7
    Bài viết cuối: 04-07-2011, 10:07 AM
  5. Chạy được trên cfree mà không chạy được trên visual studio
    Gửi bởi kienchochethahaha trong diễn đàn Thắc mắc lập trình C/C++/C++0x
    Trả lời: 4
    Bài viết cuối: 11-10-2010, 02:08 PM

Quyền hạn của bạn

  • Bạn không thể gửi đề tài mới
  • Bạn không thể gửi bài trả lời
  • Bạn không thể gửi các đính kèm
  • Bạn không thể chỉnh sửa bài viết của bạn