Từ 1 tới 5 trên tổng số 5 kết quả

Đề tài: Sau khi attach database vô SQL Sever thì bị tình trạng Read-Only và có màu đen(Database vừa attach đó)????

  1. #1
    Ngày gia nhập
    12 2010
    Bài viết
    683

    Unhappy Sau khi attach database vô SQL Sever thì bị tình trạng Read-Only và có màu đen(Database vừa attach đó)????

    Tình hình là mình đang test một app quản lý nhưng khi attach database của nó xong thì bị tình trạng Read-Only và màu của database vừa attach đó màu đen thui hà???



    Khi click vô đó để dettach hay drop thì đơ luôn SQL!!!!???

    Rồi khi tắt SQL Managerment Studio và login vô lại thì ko login dc??? Lỗi connect expire....

    Mà mình thấy thuộc tính của nó đâu có Read-Only đâu ta!!!

    Oh my god!!! Bây giờ bất cứ app nào khác không connect dc với server

    Ai gặp vấn đề này chưa vậy-Giúp mình với!!!!???
    Đã được chỉnh sửa lần cuối bởi cchangkhongayngo : 18-09-2011 lúc 05:51 PM.

  2. #2
    Ngày gia nhập
    08 2011
    Nơi ở
    Yên Bái- Hà Nội
    Bài viết
    961

    Four chưa gặp thế bao giờ. Thử gỡ ra cài lại xem được ko?

  3. #3
    Ngày gia nhập
    12 2010
    Bài viết
    683



    Có cao thủ nào giúp ko???

    Chắc chết mất thôi!!!



    Fixxxxxxxxxxx: Mò hồi sáng đến giờ! Ai dè download tiện ích từ bác bill về fix rồi xóa tận gốc datatabase chết tiệt đó!!

    Humh!!! Làm người ta khổ sở hồi sáng giờ!!!!
    Đã được chỉnh sửa lần cuối bởi cchangkhongayngo : 18-09-2011 lúc 06:16 PM.

  4. #4
    Ngày gia nhập
    10 2011
    Bài viết
    443

    Lâu rồi không thấy ai trả lời nên mình trả lời luôn. Mình nghĩ bạn thiếu chuỗi này trong kết nối.

    Code:
    Integrated Security=true
    Mình nghĩ bạn viết như thế này
    Code:
    string ketnoi = "Server=.;database=master;UId=sa;Pwd=sa;";
    Đây là đoạn code đúng
    Code:
    string ketnoi = "Server=.;database=master;UId=sa;Pwd=sa;Integrated Security=true";
    Nếu thiếu chuỗi đó thì sẽ bị 'read-only' như bạn nói.

  5. #5
    Ngày gia nhập
    08 2013
    Bài viết
    1

    Cảm ơn bạn nhiều. May quá, mình vừa đang bị như thế này
    Trích dẫn Nguyên bản được gửi bởi ndnhan Xem bài viết
    Lâu rồi không thấy ai trả lời nên mình trả lời luôn. Mình nghĩ bạn thiếu chuỗi này trong kết nối.

    Code:
    Integrated Security=true
    Mình nghĩ bạn viết như thế này
    Code:
    string ketnoi = "Server=.;database=master;UId=sa;Pwd=sa;";
    Đây là đoạn code đúng
    Code:
    string ketnoi = "Server=.;database=master;UId=sa;Pwd=sa;Integrated Security=true";
    Nếu thiếu chuỗi đó thì sẽ bị 'read-only' như bạn nói.

Các đề tài tương tự

  1. MS SQL Lỗi Không attach được database trong sql 2005, lỗi: not able to access database under current security context
    Gửi bởi hugo158 trong diễn đàn Thắc mắc Microsoft SQL Server & Microsoft Access
    Trả lời: 4
    Bài viết cuối: 19-04-2013, 02:51 AM
  2. Lỗi: The database 'CT' cannot be opened because it is version 655, không attach được database???
    Gửi bởi jackson_to trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 5
    Bài viết cuối: 05-01-2013, 12:08 PM
  3. Cách tự động attach database khi chạy chương trình ?
    Gửi bởi zalai1992 trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 3
    Bài viết cuối: 25-06-2012, 10:15 AM
  4. Lỗi chỉ cho phép đọc database khi auto attach database
    Gửi bởi tan408 trong diễn đàn Nhập môn lập trình C#, ASP.NET
    Trả lời: 0
    Bài viết cuối: 23-04-2012, 11:54 PM
  5. Database Tự Attach Database khi cài đặt chương trình
    Gửi bởi thanhhungph127 trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 1
    Bài viết cuối: 09-05-2011, 08:46 AM

Quyền hạn của bạn

  • Bạn không thể gửi đề tài mới
  • Bạn không thể gửi bài trả lời
  • Bạn không thể gửi các đính kèm
  • Bạn không thể chỉnh sửa bài viết của bạn