Từ 1 tới 6 trên tổng số 6 kết quả

Đề tài: Debug in VC++6 | One or more BreakPoints cannot be set and have been disabled.

  1. #1
    Ngày gia nhập
    09 2007
    Bài viết
    724

    Mặc định Debug in VC++6 | One or more BreakPoints cannot be set and have been disabled.

    Chào các bạn hiện giờ mình đang xài VC++6.0 để làm bài tập. nhưng không hiểu sao nó lại "giỡ chứng" không cho mình debug . mình đã vào project -> setting -> và chọn build ở chế độ debug. nhưng không hiểu sao lúc F9 đặt BreakPoint sau đó nhấn F5 thì nó show lên một cái MessageBox nói là "One or more BreakPoints cannot be set and have been disabled. Execute will stop at the beginning of the program". sau đó mình chọn ok thì nó lại show lên cho mình thấy cửa sổ "Disassembly" chứ không phải là cửa sổ code như mình vẫn thường làm.

    đây là tab debug ở cửa sổ output của mình:

    Output Code:
    1. Loaded 'ntdll.dll', no matching symbolic information found.
    2. Loaded 'C:\WINDOWS\system32\kernel32.dll', no matching symbolic information found.
    3. Loaded 'C:\WINDOWS\system32\mfc42.dll', no matching symbolic information found.
    4. Loaded 'C:\WINDOWS\system32\msvcrt.dll', no matching symbolic information found.
    5. Loaded 'C:\WINDOWS\system32\gdi32.dll', no matching symbolic information found.
    6. Loaded 'C:\WINDOWS\system32\user32.dll', no matching symbolic information found.
    7. Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2009\mzvkbd.dll', no matching symbolic information found.
    8. Loaded 'C:\WINDOWS\system32\psapi.dll', no matching symbolic information found.
    9. Loaded 'C:\WINDOWS\system32\advapi32.dll', no matching symbolic information found.
    10. Loaded 'C:\WINDOWS\system32\rpcrt4.dll', no matching symbolic information found.
    11. Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2009\mzvkbd3.dll', no matching symbolic information found.
    12. Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2009\adialhk.dll', no matching symbolic information found.
    13. Loaded 'C:\WINDOWS\system32\shlwapi.dll', no matching symbolic information found.
    14. Loaded 'C:\Program Files\Kaspersky Lab\Kaspersky Internet Security 2009\kloehk.dll', no matching symbolic information found.
    15. Loaded 'C:\WINDOWS\system32\mfc42loc.dll', no matching symbolic information found.
    16. The program 'C:\Documents and Settings\ntduc\Desktop\Tuan04\Debug\Tuan04.exe' has exited with code 0 (0x0).

    rất mong các bạn chỉ mình cách khắc phục cái này.
    thank.
    Đã được chỉnh sửa lần cuối bởi zkday2686 : 15-09-2008 lúc 01:51 AM.

  2. #2
    Ngày gia nhập
    10 2007
    Nơi ở
    /root
    Bài viết
    318

    Tớ thường đặt Breakpoint ở bắt đầu của 1 vòng lặp , cậu đặt ở đâu ?

  3. #3
    Ngày gia nhập
    09 2007
    Bài viết
    724

    Mình cũng giống bạn là thường đặt ở đầu vòng lặp( nơi cần debug). Nhưng giờ mình đã thử tất cả kể cả đầu hàm cần debug nhưng vẫn không được.

    cái này chắc do lần trước mình để chế độ Release, giờ bỏ qua chế độ debug nên nó "dỡ chứng" giờ mình không biết làm sao với nó nữa.

  4. #4
    Ngày gia nhập
    08 2006
    Nơi ở
    TpHCM
    Bài viết
    202

    Cậu không đưa project lên nên cũng khó biết, vì khi đó tui có thể biết được các setting trong project của cậu
    Nếu VC mở window "Disassembly", bạn switch trở lại window source code có thể sẽ debug được

  5. #5
    Ngày gia nhập
    07 2008
    Nơi ở
    /media/Anime
    Bài viết
    2,288

    Bạn nhấn ctrl + f10 thay cho gài breakpoint xem có bị gì ko ?
    Càng yêu mèo thì mèo càng mập. Mèo càng mập ta lại càng yêu.

  6. #6
    Ngày gia nhập
    09 2007
    Bài viết
    724

    Mặc định Debug in VC++6 | One or more BreakPoints cannot be set and have been disabled.

    Cảm ơn các bạn đã giúp đỡ. Mình đã tìm ra lỗi rồi .
    lý do là lần trước mình để chế độ build ở dạng Release nên nó thêm mấy cái NDEBUG vào mấy TextBox trong một vài tab của cửa sổ setting. nên nó không cho debug cho dù mình đã chỉnh lại build ở chế độ debug.
    Giờ chỉ cần sửa tất cả chổ nào có chữ NDEBUG thành _DEBUG là được .
    một lần nữa xin cảm ơn tất cả các bạn.
    Đã được chỉnh sửa lần cuối bởi zkday2686 : 15-09-2008 lúc 01:04 PM.

Các đề tài tương tự

  1. Lỗi khi debug chương trình C#: "Visual Studio cannot start debugging because the debug target"
    Gửi bởi Rongcon.com.vn trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 2
    Bài viết cuối: 09-05-2012, 08:46 PM
  2. [VS 2010]Khi debug bị lỗi không cho chạy debug trước đó
    Gửi bởi buxu trong diễn đàn Thắc mắc lập trình Visual C++
    Trả lời: 2
    Bài viết cuối: 08-04-2012, 04:25 PM
  3. lỗi khi chạy debug | fatal error LNK1104: cannot open file "Debug/vd1.exe"
    Gửi bởi duytuyen26 trong diễn đàn Thắc mắc lập trình Visual C++
    Trả lời: 8
    Bài viết cuối: 05-04-2012, 08:51 PM
  4. Error: "generating user instances in sql server is disabled"
    Gửi bởi changtraisitinh trong diễn đàn Thắc mắc lập trình C#
    Trả lời: 0
    Bài viết cuối: 30-03-2011, 07:55 AM
  5. #ifdef DEBUG.......#endif câu lệnh debug
    Gửi bởi RadiRadic trong diễn đàn Thắc mắc lập trình Visual C++
    Trả lời: 3
    Bài viết cuối: 07-07-2009, 10:58 AM

Quyền hạn của bạn

  • Bạn không thể gửi đề tài mới
  • Bạn không thể gửi bài trả lời
  • Bạn không thể gửi các đính kèm
  • Bạn không thể chỉnh sửa bài viết của bạn